Tips and tricks for eclipse and the IDE MyEclipse

In this Tutorial we present tips and trick for the development enviroment eclipse and the extension
MyEclipse.

Generals

Author:

Sascha Wolski

Sebastian Hennebrueder

http://www.laliluna.de/tutorial.html — Tutorials for Struts, JSF, EJB, Hibernate, xdoclet, eclipse and
more.

Datum:
January, 25 2005
Development Tools

Eclipse 3.x

MyEclipse plugin 3.8

(A cheap and quite powerful Extension to Eclipse to develop Web Applications and EJB (J2EE)
Applications. | think that there is a test version availalable at MyEclipse.)

PDF Version des Tutorials
http://www.laliluna.de/assets/tutorials/eclipse-myeclipse-tips-and-tricks-en.pdf

Table of Content
Tips and tricks for eclipse and the IDE MYECHPSE.......cccoioiieeeeeeeeee e 1
7= g T = | S SR 1
Workbench tips @nd trICKS. ... ..cooo i e e e e e e e e e e e e e 2
7= LYo Yo 1] e =T =Y SRR 2
[N F= NV To F= i TN 1] (] 2SR 3
CUSIOMIZE KEY DINAINGS....eeeeeeeeeiiee ettt e e et e e e e e et e e e e e e s nnneeeeeens 4
Key BiNdiNG ASSISTANCE........coceeiiiiiie e e e e e e e e e 4
TiliNg the ditOr WOIK @r€a........ooiiiiieiiiiie et e e e e s 5
CollAaPSE All IEEIMS...eeeeiieeeeeeeeeeeeee e e e e e e e e e e e e e e e e e e e e e e e e e e aeaas 5
Show line numbers on the text €ditOr...........ovvviiiiiiiii 5
Show line NUMDErs 0N JaVa €AItOr.............uuiiiiiiiiiiieeeeee e 6
Maximize a VIeW O €ditOr WINAOW. ...ttt e e e e e e e e e e e e e e e e e e e e e e e e aeseaaaeaaaaaannas 6
CUSTOMIZE the MENU DAK... ...t e e e e e e e e e e e e e e e e e e enneanees 6
R (o g TR0 4 ST 0¥ =T~ OSSP 7
[ Qo) o] o T=T g Yo 11 (o] = J PSRRI 7
Development tips @nd trCKS. ... ... e e e e 7
Content assist (U0 COMPIETION).........uiiiiiie e 7
Using content assist to add getter and setter methods............cccviiiiiiiiii 8
Using content assist 1o @add CONSITUCTONS. ..........uiiiiiiiii e 8
Delegate MENOAS. ........o e et e et e e e e e e e e e e e aaaaaaaaaeeaens 8
Create getter and setter Methods. ...........oooo i 9
Override and implement MEthOdS...........cooiiiii e 10
N F= A= W oo o [N (=T 0 0T 0] =1 =T U 10
QUICK fiX TUNCHON (CH 4 1) e e e e e e e e e e e ennee e e e ennnes 12
QUICK fIX ON IMPOIES. ...ttt e et e e e e e e et e e e e e e e e naeeeeeaeeeeanssneeeeeeeaanns 12
Quick fix to create @ NEeW MEethod............oo i 12
Quick fix to change method SIgNatures..............cooiiiiiiiiiii e 12
Use quick fix to add unimplemented methods............ccoo oo 13
Quick fix to surround lines with if / while / for statement............cccccov i 13
Quick fix to remove a if / while / for statement............ccovvmiiiiiiiii 13

THE OULIING WINAOW. ... e et e et e e e e e e e e e e e e e e e e e eae e e e en e e e eenns 14



MYECHPSE tiPS @Nd I1ICKS ...ttt 15

Add capabilities t0 @ PrOJECT.........u e 15
Show line numbers in MyECHPSE ©AItOr..........cccuiiiiiie e e 16
Content assist for JSP and XML FIl€S.......cooii oo 16
Design Mode fOr HTIML filES.........uuuiiiiiiiiieeeeee ettt 17
MyEclipse Database EXPIOIEr..... ...ttt e e e e e e e e e e e e e e e e e e e e e e e s e e e e nnnnes 17

Workbench tips and tricks

Select working set

You can assign one or several projects to a working set. The advantage of the working set: If you
work on many projects, you do not display all project in the package explorer.
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Set a name for the working set and assign the projects.
#= New Working Set
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On the drop down menu you can see which working set is activated. You can deselect the working
set with the option Deselect Working Set.
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Navigation History

The workbench editors holds a navigation story. If you open a second editor while you are editing,
you can press Navigate > Back (Alt + Left Arrow) to go back to the last editor. This makes
working with several open editors a whole lot easier.

Go to the last edit location
Navigate > Go to Last Edit Location (Ctrl + Q) go back to the last editing location in the editor.
You can also use the Arrow in the menu bar.
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Customize key bindings

If you use a command several time again you can assign a key binding which calls this command
by pressing the keys. You can assign new key bindings and see a list of existing key bindings on
Workbench > Keys.
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Key Binding Assistance

Eclipse supports key bindings that contain more than one key stroke. Example of such key
bindings is Alt + Shift + Q, Y (,Open Synchronize View" in the Default key configuration).

Its very hard to lern these keys and it can be hard to remember them if you don't use them very
often. It is now possible to get a little pop-up showing you the possible completions for the keys
you have pressed already. Activate the option Help Me With Multi-Stroke Keyboard Shortcuts
in the Tab Advanced under Window > Preferences > Workbench > Keys.
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Tiling the editor work area

You can use drag and drop to modify the layout of the editor work area. Grab an editor tab and
drag it to the egde of the editor work area. The black arrow show you the way.
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Collapse all items

With the button Collapse All on your tool bar of the navigator (or similar views) you can collapse
all expanded project or folder items.
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Show line numbers on the text editor

Open the properties of eclipse, Window > Preferences and check Show line numbers on
Workbench > Editor > Text Editor to show the line numbers in the text editor.
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Show line numbers on java editor

Showing the line numbers on java editor can be set on Window > Preferences. Check Show line
numbers on Java > Editor.
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Maximize a view or editor window

Double click on the view or editor tab to maximize it. Double click on a maximized tab to restore
the size. The standard short cut is ,Ctrl + M“.
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Customize the menu bar

On Window > Customize Perspective you can customize the main tool bar and the menu bar.
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Switch workspaces

To change the workspace without exiting ecplise you can use the function File > Change
Workspace.

List of open editors

Ctrl + E can be used to show a list of all open editors. Within the list you can choose a editor by
selecting it with the mouse or filter the editors by typing the name. It is usefull if you work on
several editors at the same time.
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Development tips and tricks

Content assist (auto completion)

By pressing the key combination Ctrl + Space a popup window appears with a list of auto
completions or a auto completion will be chosen automatically. You can use the same functionality
on JavaDoc comments.

The assist can be used on methods, parameters, variables and field names to speed up the
development.
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Using content assist to add getter and setter methods

You can add getter or setter methods with the content assist. Type the first letters of the getter or
setter and press (Ctrl + Space), then you can choose the getter or setter.

public class TestClaszs |

private File file = new File("C:/");

Set

@ setFileFile) woid - Setter for File' =
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Using content assist to add constructors

Type the first letters of the constructor on the place where constructor will be added and use the
content assist (Ctrl + Space).

Pro

& ProblemDecarator) - Defaulk construckar
® ProblemDecaratar{default package) %
® Process - java.lang

Delegate methods

Eclipse provide a wizard to add delegate methods. This is useful when you use frequently
composition of classes.

In the editor right click and then Source > Generate delegate Methods or you define a key
binding to call the delegate wizard (Window > Prefrences > Workbench > Keys) .

An example for a delegate method:

String string = new String();

/**
* delegate method
v
public char charAt (int arg0) {
return string.charAt (arg0) ;

}



Create getter and setter methods

Eclipse provides the option to generate getter and setter methods for attributes of classes. Right
mouse button in the editor Source > Generate Getters and Setters or you define a key binding to
call the wizard (Window > Prefrences > Workbench > Keys).
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Override and implement methods

Eclipse provides an assistant to implement and override methods. For example, when you
implement a interface you do not type the methods of the interface by hand.

In the editor right mouse button > Source > Override/Implement Methods.
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Java code templates

A template can be used to create a method or other source code. Open the properties of eclipse
(Window > Preferences) and choose Java > Editor > Templates. Create a new template by
pressing on New.
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In the pattern window you can create your template. A placeholder for later filling with data can be
defined by the syntax ${name}.
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After creating the template you can use it with the content assist by typing the first letters and the

shortcut Ctrl + Space.
Fpuhlic class TestClass 1

mel
B _mei) void - Method stub
=| _method_header - create a method header

Pressing tab to jump between the place holders.

public class TestClass |
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Quick fix function (Ctrl + 1)

You can use the quick fix function for several tasks.

Quick fix on imports

Use the quick fix function (Ctrl + 1) to remove the never used imports automaticly. Set the cursor
on the import area and press Ctrl + 1 and choose in the popup menu the option Organize
Imports.

=] File1 | =] Filez | |=] File Il #TestClass java X
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& < Remove import
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Quick fix to create a new method

If you call a method which does not exists, quick fix can add the method for you. Set the cursor on
the method and press Ctrl + 1.

public String TestMethodi() {
File file:

return RegdFile(file)

b E Create method ‘ReadFile(File)
& Rename in File

Quick fix to change method signatures

Quick fix can modify method signatures for you. If you call a method with additional parameters
use quick fix to change or create the method.

bru:n:ess [action, true);

= Remove argument to match ‘process{Iaction)’
57 Change method 'processiIaction)’; Add parameter 'boolean’
® Create method 'process(IAction, boolean)'




Use quick fix to add unimplemented methods

If you implement an interface you can use quick fix to add the unimplemented methods. Set the
cursor to the class name, press Ctrl + 1 and choose Add unimplemented methods.

0 public class bataIteratDr implements Iterator {

@ Add unimplemented methods
@ Make bype 'Datalteratar’ abstrack

Quick fix to surround lines with if / while / for statement

Select the lines which you want to surround with a if / while / for statement and choose the
template in the quick fix popup window (Ctrl + 1). All templates with the variable ${line_selection}
will be displayed in the list.

f (condition) {
Syskerm, ouk, prinkindHella");

=| Surround with 'da’ {do while statement)

= qurround with ‘far' (iterake over array)
Surround with 'if* GiF skatenmeant)

= Surround with 'runnable’ {runnable)
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Quick fix to remove a if / while / for statement

To remove a if / while / for statement set the cursor to the closed braket and press Ctrl + 1.

if (text.lengthi{) = 0O} {
return text:
i

"; Remove surrounding 'if' statement



The outline window

The easiest way to get an overview of a class or an XML file is using the outline window. You can
activate it on Window > Show View > Outline or use the key binding Alt + Shift + Q, O.
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If you open a class in the editor you will see the content (imports, attributes and methods) of the

class in the outline window.
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import declarations
java. nio, BuFfer

string & Skring
@ methodOned)
@ methodTwol)

The outline window can not only be used to illustrate the content of a class or XML file, it can also

be used to work with the content.

If you choose a item of the outline window, the cursor jumps to the item in the editor, so it is an

easy way to navigate through the class.

By pressing the right mouse button on an item, for example a method, you can choose several

actions. The outline window provides mu

Itiselection, for example to delete the items.
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MyEclipse tips and tricks
Add capabilities to a project

MyEclipse provides a wizard to add capabilities for struts, JavaServer faces and hibernate. Right
click on the project and choose one of the capabilities. You also can add the JSTL Libraries to
your project.

Restore from Local Histary, .. I
MyEclipse &dd and Remove Project Deplovments., ..

Properties Alt+Enter add Struks Capahbilities. ..
Add J5F Capabilities. ..

Add JSTL Libraries
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On Window > Preferences > MyEclipse > Project Capabilities you can customize the
capabilities (Libraries und other files).

Show line numbers in MyEclipse editor

To show the line numbers in JSP, HTML, JavaScript, etc files check Show line numbers on
Window > Preferences > MyEclipse > Editors > Common Editor Preferences.
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Content assist for JSP and XML Files

With MyEclipse it is also possible to use the content assist in JSP and XML files. Type the first
letters and press Ctrl + Space.

H} *ispeditar . htmi 1J% 0 B

<%0 page language="Jjava™ import="java.util.*" >
<%

String path = redgquest.
gtring basePath =

TeqU ofBASIC_AUTH String - HibpServistRequest -
&

o CLIEMT _ZERT_AUTH String - HttpServletReguest
o DIGEST_AUTH String - HekpServletReguest

@ equals{CObject argd) boolean - Ohject

o FORM_AUTH  String - HEbpSeryletRequest
getAttributelstring argd) Object - ServletRequest
@ get.ﬁ.ttril:uu ames() Enumeration - ServietRequest

@ getAuthTypel) String - HEEpServletRequest "

b3 b

< !DOCTYPE HTML PUELIC
<htrmlx>
<head:>
<hase href="<%=has

<titlexMy JSP 'Myd




The assist supports tags of tag libiries too, for example struts or JavaServer faces.
<hody> 4________-----(ZlnvntE:nt Assist
<html:
<html:
<takh
<t

< ¥ html:base -
< ¥ htrnl: butkon

< ¥ html: cancel

< ¥ html: checkbox

< » html:errors

</ ¢ bl file

“T ¢ » html:Farm

< » htrnl: Frame

< ¥ html: hidden
<=

A

<td colspan=":Z" align="center"><html:suln

Design Mode for HTML files

MyEclipse provides a WYSIWYG editor to create HTML files. Open a HTML file in the editor and
choose in the left edge the tab Design.

Note: There is a preview function too.
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MyEclipse Database Explorer

If you work with databases and do not want to left MyEclipse each time, there is a database
explorer you can use to view or modify data in your database. You can choose the perspective of

the MyEclipse Database Explorer under Window > Open Perspective > Other or select the icon
in the symbol bar of the perspectives.
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At the top of the database browser you will find the tool bar, which you can use to do different
functions.

K@DE Browser i =]
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You can do different actions with a table like Edit table data, Create Table Script etc. A special
action is to create hibernate mappings.
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